package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<([^<]*?)>`)
var str = `<UserInput Question="test Q?" Answer=<value>0</value><sam@testmail.com>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}