import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "INIT\\s*--\\s*(?<label>\\w+)\\n\n"
+ "\\s+UP:\\s*(?<up>\\d+)\\n\n"
+ "(?<uplines>(?:\\s+(?!\\s*DOWN).*\\n)*)\n"
+ "\\s+DOWN:\\s*(?<down>\\d+)\\n\n"
+ "(?<downlines>(?:\\s+(?!\\s*INIT).*\\n)*)";
final String string = " INIT -- FOO\n"
+ " UP: 1\n"
+ " UpLine #1\n"
+ " DOWN: 2\n"
+ " DownLine #1\n"
+ " DownLine #2\n\n"
+ " INIT -- BAR\n"
+ " UP: 0\n"
+ " DOWN: 2\n"
+ " DownLine #1\n"
+ " DownLine #2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}