re = /^.*(?=(?:color|background-color|background-image)\:.*?;).*/m
str = 'header p {
color:#f2f3ed;
background-color:#353535;
background-image: url(../images/dots.png);
}
header p {
background-image: url(../images/dots.png);
background-color:#353535;
color:#f2f3ed;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end