#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\w{2,})(\s|=)('|\")(#|\s|\w.*?('|\"))"
Local $sString = "<a href= "#">asd</a>" & @CRLF & _
"" & @CRLF & _
"<b href="dfg">asd</b>" & @CRLF & _
"<u href="#">asd</u>" & @CRLF & _
"<i href="#">asd</i>" & @CRLF & _
"<em href="http://google.com">asd</em>" & @CRLF & _
"" & @CRLF & _
"<b>asd</b>" & @CRLF & _
"<u>asd</u>" & @CRLF & _
"<i>asd</i>" & @CRLF & _
"<em>asd</em>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")