# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/__(.*?)\s*__\s*/<u>$1<\/u> /gm;t' <<< "__underline a sentence __and more.
__underline a sentence__ and more."