const regex = /class="imgbrd lazy"([\s\S]*?)src=".*?"/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('class="imgbrd lazy"([\\s\\S]*?)src=".*?"', 'gi')
const str = `<img class="imgbrd lazy" src="/something/iage.png" data-original="/albums/uploadedpics/small1/017246.jpg" border="0">`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);