// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)class="imgbrd lazy"([\s\S]*?)src=".*?""#).unwrap();
let string = "<img class=\"imgbrd lazy\" src=\"/something/iage.png\" data-original=\"/albums/uploadedpics/small1/017246.jpg\" border=\"0\">";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}