package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:[.,]\d+)*$`)
var str = `1234
1,234
1.234
1,23,334
1.23.334
1,23,334.00
1.23.334,00
1,23...233
1,23.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}