const regex = /[*:]|(?<!B~)[~](?![~])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[*:]|(?<!B~)[~](?![~])', 'gm')
const str = `ABCHKLJNKL*dskjnsdfkdsmflkmdls MLKMLKML~KMLKMLKMMML zlmlkmm:skjnjnskfjnkjsdnkfjnkdjs B~~KJNNKJNJNKKJNKJNFKKJNJNK`;
const subst = `@`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);