#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^([a-z0-9_\/\-]+)\/([a-z0-9_\-]+[\.]{1}(jpg|jpeg|png|gif))$"
Local $sString = "path/to/my-photo.jpeg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")