import re
regex = re.compile(r"(?:^.|.@.|.\.\w+$)(*SKIP)(*F)|.", flags=re.MULTILINE)
test_str = "xyzdsdasdas@xyss.com"
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)