import Foundation
let pattern = #"(?:^.|.@.|.\.\w+$)(*SKIP)(*F)|."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"xyzdsdasdas@xyss.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)