import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\n)(\\d+:\\d{4}) (\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2}\\.\\d{3}) ([A-Za-z\\n]+) (.*?)(?=\\n\\d+:|$)";
final String string = "5376:0084 2015-08-07 13:51:29.103 Error ### Error Message ###\n"
+ "5376:0084 2015-08-07 13:51:35.545 Error Discarding invalid session\n"
+ " System.Web.Services.Protocols.SoapException: Verify Session ID failed\n"
+ " at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)\n"
+ " at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)\n"
+ "5376:0084 2015-08-07 13:51:36.013 Error ### Error Message ###";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}