re = /^(?:0*(?:[0-9]|[1-9][0-9][0-9]?|[1-4][0-9][0-9][0-9])(?:[.][0-9])?|5000(?:[.]0)?)$/m
str = '5000
4999.9
25.0
2500.9
0.4
5000.5
5000.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end