using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(010002)[\s\S]*INTEREST";
string input = @"010002 D324Y56HY INTEREST
010002 SAD21 INTEREST";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}