using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+|\D+|[d+ &])";
string input = @"Mr Smith 10 Rillington Place Exeter Devon
Smith & Sons Ltd. 10 & 12 High Street Sutton Surrey[]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}