package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<.*?>)(.*)(<.*?>)`)
var str = `<h3 class="heading">General Purpose</h3>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}