$re = '/(<.*?>)(.*)(<.*?>)/';
$str = '<h3 class="heading">General Purpose</h3>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);