use strict;
my $str = '-fjdkls six-nation-golden-cup-award - jfkdl-';
my $regex = qr/\b-\b/p;
my $subst = '\\\\-/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";