$re = '/\b-\b/';
$str = '-fjdkls six-nation-golden-cup-award - jfkdl-';
$subst = "\\-/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;