re = /\b-\b/
str = '-fjdkls six-nation-golden-cup-award - jfkdl-'
subst = '\\\\-/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result