import Foundation
let pattern = #"(file\/d\/)([a-zA-Z0-9]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://drive.google.com/file/d/0B1N6sAoTkkeKeGlxdDZQYUZhbEE/view?usp=sharing"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}