#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?P<schema>.*://)?(?P<cedentials>.*@)?(?P<www>www\.)?(?P<domain>[\w\.]+)(?P<path_query>/?.*)?"
Local $sString = "http://user:password@www.example.com" & @CRLF & _
"https://www.example.com/some/path?query=foo" & @CRLF & _
"https://www.example.com/some/path" & @CRLF & _
"http://www.example.com/some/path" & @CRLF & _
"https://example.com/some/path" & @CRLF & _
"http://example.com/some/path" & @CRLF & _
"https://example.com/" & @CRLF & _
"http://example.com/" & @CRLF & _
"www.example.com/some/path" & @CRLF & _
"www.example.com" & @CRLF & _
"www.example.com/" & @CRLF & _
"example.com/some/path" & @CRLF & _
"example.com" & @CRLF & _
"subdomain.example.com" & @CRLF & _
"example.co.uk" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")