re = /[a-zA-Z0-9]*-[a-zA-Z0-9]*-[a-zA-Z0-9]*-[a-zA-Z0-9]*-[a-zA-Z0-9]*/m
str = 'iPad Pro (12.9-inch) (4th generation) (CE714306-8B25-4DEE-AF23-F93C20DFEE3F) (Booted)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end