re = /\[[^\]]+\]\([^\)]+\)|(\(\b)/
str = '[My Link Title](http://example.com)
(extension: value attribute: value)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end