import re
regex = re.compile(r"[#.][-_]?[_a-zA-Z]+(?:\w|\\.)*|(?<=\s+|^)(?:\w+|\*)|\[[^\s\"'=<>`]+?(?<![~|^$*])([~|^$*]?=(?:['\"].*['\"]|[^\s\"'=<>`]+))?\]|:[\w-]+(?:\(.*\))?", flags=re.MULTILINE)
test_str = (".class {}\n"
".class .class {}\n"
".class #id {}\n"
"tag #idtag {}\n"
"[attribute] {}\n"
"[attribute*=\"value\"] {}\n"
"[attribute$=value] {}\n"
".class:not(.class) {}\n"
".clas\\$s tag\n"
".class:nth-child(2n+8):nth-of-type(-n+15)\n"
"tag *")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")