#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^(?'User'[_a-z0-9-]+(\.[_a-z0-9-]+)*)@(?'Domain'[a-z0-9-]+(\.[a-z0-9-]+)*\.[a-z]{2,4})$"
Local $sString = "kevi.metal.maty.rock@goo.gle.ma.il.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")