re = /^(?'User'[_a-z0-9-]+(\.[_a-z0-9-]+)*)@(?'Domain'[a-z0-9-]+(\.[a-z0-9-]+)*\.[a-z]{2,4})$/i
str = 'kevi.metal.maty.rock@goo.gle.ma.il.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end