re = /value=\"([\w]+)\"/
str = '<input type="hidden" name="csrfmiddlewaretoken" value="676248f0994e62274dea72023fe699ff">'
# Print the match result
str.match(re) do |match|
puts match.to_s
end