#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)package\s+(?:\w+\s+)?([^\s]+)\s+is(.*?)end\s+(package|\1)\s*;"
Local $sString = "package p_dio_bfm is" & @CRLF & _
" procedure setBFMCmd ( " & @CRLF & _
" variable pin : in tBFMCmd" & @CRLF & _
" );" & @CRLF & _
"end p_dio_bfm; -- end package;" & @CRLF & _
"" & @CRLF & _
"package body p_dio_bfm is" & @CRLF & _
" procedure setBFMCmd ( " & @CRLF & _
" variable pin : in tBFMCmd" & @CRLF & _
" ) is" & @CRLF & _
" begin" & @CRLF & _
" bfm_cmd := pin;" & @CRLF & _
" end setBFMCmd;" & @CRLF & _
"end p_dio_bfm;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")