#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:((\d+(?=[^.]+|\.{2,})).)+|(\d\.){2,}).*|[^\d]+$"
Local $sString = "1" & @CRLF & _
"" & @CRLF & _
"1.7654" & @CRLF & _
"" & @CRLF & _
"-2.5" & @CRLF & _
"" & @CRLF & _
"2-" & @CRLF & _
"" & @CRLF & _
"2...33" & @CRLF & _
"" & @CRLF & _
"m" & @CRLF & _
"" & @CRLF & _
"2..3" & @CRLF & _
"" & @CRLF & _
"2....233..6" & @CRLF & _
"" & @CRLF & _
"2.2.8" & @CRLF & _
"" & @CRLF & _
"2--5" & @CRLF & _
"" & @CRLF & _
"6-4-9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")