package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)%?(.{2})$`)
var str = `123456%89
12345689`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}