package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^define\(\s*['"]*(.*?)['"]*[\s,]+['"]*(.*?)['"]*\s*\)`)
var str = `define("My_KEY", "My_Value l");
define('My_KEY', 'My_Value');
define( 'My_KEY' , "My_Value" );
define( 'My_KEY' , 'My\'_\'Value' );
define( 'My_KEY' , "My'_'Value" );`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}