// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)^define\(\s*['"]*(.*?)['"]*[\s,]+['"]*(.*?)['"]*\s*\)"#).unwrap();
let string = "define(\"My_KEY\", \"My_Value l\");
define('My_KEY', 'My_Value');
define( 'My_KEY' , \"My_Value\" );
define( 'My_KEY' , 'My\\'_\\'Value' );
define( 'My_KEY' , \"My'_'Value\" );";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}