# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\+?0*3*0*|[^\s\d]//gm;t' <<< "+331234567
+3301234567
00331234567
003301234567
0331234567
033-123-456-7
0033.1234567"