package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?0*3*0*|[^\s\d]`)
var str = `+331234567
+3301234567
00331234567
003301234567
0331234567
033-123-456-7
0033.1234567`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}