// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+?0*3*0*|[^\s\d]").unwrap();
let string = "+331234567
+3301234567
00331234567
003301234567
0331234567
033-123-456-7
0033.1234567";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}