package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)lednet(.*)\.exe`)
var str = `lednet 1043.exe
lednet 1045.exe
lednet.exe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}