#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<nthBase>[+-]?\d+)(?:\*?(?<series>n)(?<crementer>[+-]\d+)?)?$"
Local $sString = "2n+1" & @CRLF & _
"2n" & @CRLF & _
"444" & @CRLF & _
"-22" & @CRLF & _
"+4n" & @CRLF & _
"-5*n" & @CRLF & _
"-5*n-3" & @CRLF & _
"-5n+44" & @CRLF & _
"--5" & @CRLF & _
"++5" & @CRLF & _
"-" & @CRLF & _
"+" & @CRLF & _
"-6-1" & @CRLF & _
"62-1" & @CRLF & _
"62n-1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")