re = /(?=([A-Z][a-z]+)([A-Z][a-z]+)([A-Z][a-z]+)?([A-Z][a-z]+)?([A-Z][a-z]+)?)(?=(\1\2))(?=(\6\3)?)(?=(\7\4)?)(?=(\8\5)?)\1/
str = 'SomeCamelStringToCombine'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end