$re = '/(?<inEligType>O9|EO|HJ|J8)(?<msgCode>\w{4})(?<msgLen>\d{4})/';
$str = 'O9C2700021Not eligible for SDWCEOC3900015Service upgradeHJC3900015Service upgradeJ8C5000016Delivery Attempt
// (?<inEligType>O9|EO|HJ|J8)(?<msgCode>\\w{4})(?<msgLen>\\d{4})
//
// (O9|EO|HJ|J8)(\\w{4})(\\d{4})
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);