package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?://)?([^/]+)`)
var str = `www.example.com/
https://example.com/
example.com
example.com/boo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}