re = /^(?:https?:\/\/)?([^\/]+)/m
str = 'www.example.com/
https://example.com/
example.com
example.com/boo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end