#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*?[=|;].*)"
Local $sString = "xxx OR 1=1" & @CRLF & _
"1 OR 1=1" & @CRLF & _
"XXXXX; DROP TABLE *" & @CRLF & _
"123 ; SELECT *" & @CRLF & _
"é só um nome" & @CRLF & _
"nome" & @CRLF & _
"123" & @CRLF & _
"4444" & @CRLF & _
"5555555" & @CRLF & _
"xxxx or 1=1" & @CRLF & _
"XXXXX; DROP TABLE *"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")