using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?[=|;].*)";
string input = @"xxx OR 1=1
1 OR 1=1
XXXXX; DROP TABLE *
123 ; SELECT *
é só um nome
nome
123
4444
5555555
xxxx or 1=1
XXXXX; DROP TABLE *";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}