#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z]+) ([a-z]*) (.+)*$"
Local $sString = "Salix x sepulcralis 'Chrysocoma'" & @CRLF & _
"Aesculus x carnea" & @CRLF & _
"Prunus 'Accolade'" & @CRLF & _
"Acer campestre 'Elsrijk'" & @CRLF & _
"Abies alba" & @CRLF & _
"Betula utilis var. jacquemontii" & @CRLF & _
"Crataegus crus-galli" & @CRLF & _
"Crataegus laevigata 'Paul's Scarlet'" & @CRLF & _
"Ilex 'Nellie R. Stevens'" & @CRLF & _
"Sorbus x thuringiaca 'Fastigiata'" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")