package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z]+) ([a-z]*) (.+)*$`)
var str = `Salix x sepulcralis 'Chrysocoma'
Aesculus x carnea
Prunus 'Accolade'
Acer campestre 'Elsrijk'
Abies alba
Betula utilis var. jacquemontii
Crataegus crus-galli
Crataegus laevigata 'Paul's Scarlet'
Ilex 'Nellie R. Stevens'
Sorbus x thuringiaca 'Fastigiata'
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}