// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)").unwrap();
let string = "HIT & REPLACE
11/21/1994
12/11/2014
03/31/2016 # Hit only if unchecked for length months/days
NO-HIT
11//12/2090
37/14/2015
20/27/2011
10/32/1964
14/03/2020
HINTS
- Use g-flag only.
";
let substitution = "$1,$1,$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}