package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+ISHOULDNOTBEHERE.+\n.+\n<\/myXMLTag>`)
var str = `<myXMLTag id="Text1.Text2.Text3">
<Anything/>
</myXMLTag>
<myXMLTag id="Text1.ISHOULDNOTBEHERE.Text3">
<Anything/>
</myXMLTag>
<myXMLTag id="Text1.Text2.Text3">
<Anything/>
</myXMLTag>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}