import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)LOC\\s+\\[(?<LOC>[^\\]]+).*Channel:\\s+(?<Channel>.*)\\s+offset\\s+level:\\s+(?<offset>.*)";
final String string = "035: Aug 17, 2021 6:45:33 TYPE: LOC [+46.2 degC]\n"
+ "-0.3200 ddm [ 90 Hz pred] 90Hz: 35.15 %mod 150Hz: 3.15 %mod\n"
+ "Channel: 110.50 MHz -4.84 KHz offset level: -61.0 dBm\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}